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Tutorial 10: Smart security system 

1. Introduction 

Safety is a major issue when it comes to housing and accommodation. Security is 

becoming a major issue and a selection argument in the choice of accommodation. 

Connected homes offer a range of security options and solutions to make your home a 

safer place. The devices presented in this module can help you detect any presence or 

intrusion, manage whether or not to authorize entry, and secure your entry into the 

accommodation.  

Thanks to this tutorial, you'll discover connected home solutions that will enable you to 

increase your security. The tutorial is based on a multiple-entry scenario. The scenario is 

as follows: Detection and alert of an arrival, whether it's a guest or the owner. The devices 

detect a presence, authenticate you with a connected badge system and manage whether 

or not to authorize entry. 

1.1. Learning Objectives 

● Understand the use and characteristics of PIR motion sensor; 

● Understand the use and characteristics of a passive buzzer; 

● Understand the use and characteristics of the OLED I2C; 

● Understand the use and characteristics of the RFID module; 

● Create a smart home security system. 

1.2. Theoretical background 

1.2.1. What is a PIR motion sensor? 

A Passive Infrared (PIR) motion sensor is an electronic device designed to detect infrared 

radiation emitted by objects within its field of view. Unlike an active sensor that emits 

energy to form an image, a PIR sensor passively receives infrared radiation. These 

sensors are commonly used in security systems, lighting control, and other applications 

where detecting motion is essential. 

 

Figure 1 PIR motion sensor 

The PIR motion sensor consists of a pyroelectric sensor that can detect changes in the 

infrared radiation level. When an object, such as a person or animal, enters the sensor's 

range, the infrared energy emitted by the object causes a change in the sensor's voltage 
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or electrical signal. This change is then processed by the sensor's electronics, triggering 

an output signal. 

 

PIR sensors are often employed in conjunction with other electronic components to create 

motion-activated systems. For example, in security systems, when the PIR sensor detects 

motion, it can trigger an alarm or activate a camera to capture images. In lighting control 

applications, PIR sensors can be used to turn on lights when motion is detected and turn 

them off when the area is no longer occupied, contributing to energy efficiency. 

These sensors are widely used due to their simplicity, reliability, and low power 

consumption. They play a crucial role in enhancing the functionality of various devices, 

providing a responsive and energy-efficient way to detect and respond to motion in their 

surroundings. 

 

1.2.2. What is a passive buzzer? 

A 5V passive buzzer is an electronic component that generates sound or an audible tone 

when an electrical voltage of approximately 5 volts is applied to it. It is called "passive" 

because it doesn't have its own oscillating circuit to produce different tones or frequencies; 

instead, it emits a single tone or sound when powered. 

 

Figure 2 5V Passive buzzer 

These buzzers are commonly used in various electronic projects and devices to provide 

audio feedback, alerts, or alarms. They are often found in applications such as electronic 

games, alarms, timers, and other situations where a simple audible signal is needed. 

When the 5V voltage is applied, the buzzer's internal piezoelectric element or magnetic 

coil vibrates, creating the sound or tone. 

Users can control the duration and frequency of the sound produced by controlling the 

duration and timing of the voltage applied to the buzzer. It's important to note that while a 

5V power supply is common for these buzzers, the specific voltage requirements may vary 

depending on the manufacturer and model, so it's advisable to check the datasheet or 

specifications provided by the buzzer's manufacturer for precise operating details. 
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1.2.3. What is an OLED I2C SSD1306? 

Imagine an "OLED I2C SSD1306" display like a tiny TV screen for your electronic projects. 

This small screen uses a technology called OLED (Organic Light Emitting Diode) to show 

bright and clear images. 

The term "SSD1306" refers to a small computer inside the screen that helps control it. And 

the I2C interface is a bit like a special language that allows this screen to communicate 

easily with other electronic parts. 

This OLED display works with a 5-volt power supply and can be used in all sorts of 

electronic projects you can think of. The OLED technology makes the images on this 

screen really nice, with good contrasts and a clear view, and it also uses less power than 

other types of screens. 

 

Figure 3 OLED I2C SSD1306 

The I2C interface makes connecting this screen to other electronic devices very 

straightforward. This means you can easily control it with a small computer called a 

microcontroller or a development board. 

In summary, the OLED I2C SSD1306 display is a little screen that uses special technology 

to show images, and it's easy to use in many different electronic projects. 

 

1.2.4. What is a RFID Reader RC522? 

An RFID Reader RC522 is a device designed to read RFID tags, which are small electronic 

chips that store data. This reader operates on a 5V power supply and communicates with 

RFID tags using radio waves. Unlike some systems that need batteries, RFID tags 

powered by the RC522 respond when they come near the reader. 
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Figure 4 RFID Reader RC522 

This kind of RFID reader is often used to control access, such as opening doors. When 

you bring an RFID tag close to the RC522 reader, it sends out a signal that powers up the 

tag. The tag then responds with its unique ID, allowing the reader to identify it. 

The RC522 reader is handy in various applications, from security access systems to 

inventory tracking. It's commonly used in projects where you want to use RFID technology 

for tasks like opening doors, managing attendance, or tracking items. 

 

1.3. Material 

For this tutorial you will need the following material: 

● Raspberry Pi Pico  

● 16 x Male-to-female jumper wires 

● Full size breadboard  

● PIR motion sensor  

● Micro-USB cable 

● Buzzer  

● 1 x OLED I2C SSD1306 display  

● RFID RC522 module  

● RFID Tag 

 

2. Initial steps & Connectivity 

Open Thonny Python, then go to File 🡪 Save as…, choose Raspberry Pi Pico, and save 

your file under the name securitysystem.py. Then it is time to connect the electronics 

and write your program. Please follow the instructions below. Note that each step comes 

with an instructional video showing how it should be executed. If you are not sure about 

the components used in this tutorial, please advise the SmartHome Kit Manual and the 

relevant chapter in the SmartHome Guide. 

To connect all these components, please follow the wiring diagram below: 
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PIR motion sensor: 

- Red cable is connected to 5V rail (+) 

- Black cable is connected to GND rail (-) 

- Yellow cable is connected to GPIO22 pin 

 

Passive buzzer: 

- Connect the longer end (+) of the buzzer to GPIO6 pin 

- Connect the shorter end (-) of the buzzer to a GND pin 

 

OLED I2C SSD1306 display: 

- Red cable is connected to 3v3 rail (+) 

- Black cable is connected to GND rail (-) 

- Green cable is connected to GPIO14 I2C1 SDA pin 

- Blue cable is connected to GPIO15 I2C1 SCL pin 

 

RFID Reader RC522: 

- 3v3 (red cable) is connected to 3v3 rail (+) 
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- GND (black cable) is connected to GND rail (-) 

- RST (purple cable) is connected to GPIO28 pin 

- SDA (green cable) is connected to GPIO17 pin 

- SCK (yellow cable) is connected to GPIO18 pin 

- MOSI (orange cable) is connected to GPIO19 pin  

- MISO (blue cable) is connected to GPIO16 pin 

Before starting programming the OLED display, you first need to add the SSD1306 

package to your Raspberry Pi Pico. To do that, please follow the next steps: 

1. Open Thonny and go to Tools → Manage packages… 
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2. In the manage packages window, type SSD1306 and click Search. 

 

3. Once search is over, click on the micropython-ssd1306. 
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4. On the next window, click Install. 

 

5. Wait for package installation, then click close. 

 

Now, you are ready to proceed with programming the OLED display and all other 

sensors and electronics. 

3. MicroPython code 

The following code creates a smart security system that allows you to detect a presence, 

activate a buzzer, use an RFID device and manage whether or not to authorize entry. To 

do that, first you will need to add a library to your Raspberry Pi Pico.  

Open Thonny Python and create a new file by clicking File → New or by hitting Ctrl+N on 

your keyboard. 

Then make sure the Raspberry Pi Pico is connected. You should see on the right corner 

of Thonny’s window the message “MicroPython (Raspberry Pi Pico)”. If this is not the case, 

please jump back to the Kit’s manual and follow the instructions on how to properly install 

the firmware. 

Be aware that we need an additional library that controls the RFID module, namely the 

MFRC522 library. We can download it from https://github.com/wendlers/micropython-

mfrc522/blob/master/mfrc522.py 

Download the file and open it in Thonny Python. Then click File → Save as… choose 

Raspberry Pi Pico and save your file under the name mfrc522.py. 

You are now ready to create the smart security program. Save the file as 

securitysystem.py and choose Raspberry Pi Pico as the saving destination. Copy the 

https://github.com/wendlers/micropython-mfrc522/blob/master/mfrc522.py
https://github.com/wendlers/micropython-mfrc522/blob/master/mfrc522.py
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program below, or simply write it yourself to practice. There is also a step-by-step video 

tutorial of the program creation. Make sure to check that out as well. 

 

from machine import Pin, I2C 

from mfrc522 import MFRC522 

from ssd1306 import SSD1306_I2C 

from time import sleep 

 

# Define pins for each component 

PIN_BUZZER = 6 

PIN_PIR = 22 

PIN_SDA = 17 

PIN_SCK = 18 

PIN_MOSI = 19 

PIN_MISO = 16 

PIN_RST = 28 

PIN_SDA_OLED = 14 

PIN_SCK_OLED = 15 

 

# Setup buzzer 

buzzer = Pin(PIN_BUZZER, Pin.OUT) 

buzzer.value(0) 

 

# Setup PIR sensor 

PIR = Pin(PIN_PIR, Pin.IN, Pin.PULL_UP) 

 

# Setup for OLED display 

WIDTH = 128 

HEIGHT = 64 

i2c = I2C(1, sda=Pin(PIN_SDA_OLED), scl=Pin(PIN_SCK_OLED)) 

oled = SSD1306_I2C(WIDTH, HEIGHT, i2c) 

oled.fill(0) 

 

# Setup RFID Reader RC522 

RFID = MFRC522(spi_id=0, sck=PIN_SCK, miso=PIN_MISO, 

mosi=PIN_MOSI, cs=PIN_SDA, rst=PIN_RST) 

 

print("System initialized") 

 

while True: 

    # PIR Motion Sensor 

    if PIR.value(): 

        print("Motion detected!") 
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        # OLED display 

        oled.text("Motion detected!", 0, 0) 

        oled.text("Please scan", 0, 10) 

        oled.text("your fob", 0, 20) 

        oled.show() 

 

        # RFID Reader RC522 

        print("Bring RFID FOB closer...") 

        while True: 

            RFID.init() 

            (stat, tag_type) = RFID.request(RFID.REQIDL) 

            if stat == RFID.OK: 

                (stat, uid) = RFID.SelectTagSN() 

                if stat == RFID.OK: 

                    fob = int.from_bytes(bytes(uid), "little", 

False) 

                    print("FOB ID:", fob) 

 

                    # OLED display 

                    oled.fill(0) 

                    if fob == 470550832:  # change number to your 

fob ID 

                        oled.text("Access GRANTED", 0, 30) 

                        print("Access GRANTED") 

                    else: 

                        oled.text("Access DENIED", 0, 30) 

                        print("Access DENIED") 

                        buzzer.toggle() 

                        sleep(0.5) 

                    oled.show() 

                    sleep(5) 

                    oled.fill(0) 

                    break 

 

    # Additional sleep for stability 

    sleep(3) 

 

   

This code combines the functionalities of the provided snippets into one program. Please 

replace the placeholder FOB ID with the actual ID you obtained during the RFID scanning 

process. 
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4. Application on SmartHome 

Now it is time to test your code and circuit on your SmartHome. Make sure to save the 

MicroPython code in the Raspberry Pi Pico under securitysystem.py name, as 

instructed at the beginning of the tutorial. 

To do the installation on the SmartHome model you will need the following materials: 

● 1 x RFID RC522 module  

● 1 x RFID Tag 

● 1 x OLED I2C SSD1306 display 

● 1 x buzzer 

● 1 x PIR motion sensor  

● 12 x M2 metal nut 

● 12 x metal screws 

● 7 x Male-to-female jumper wires  

● 7 x Male-to-male jumper wires 

● Phillips head screwdriver 

● Pliers (optionally) 

Once all the components have been installed, click on the Play button in Thonny and wave 

your hand over the motion detector. If your code and circuit are correct, then you should 

hear the buzzer ringing. Then you can activate the RFID chip with the badge to validate 

your entry. Finally the OLED will say "Access denied" or "Access granted". 

5. Summary 

Through this tutorial, you've just explored connected home solutions that empower you to 

enhance your security. The tutorial walked you through a multi-step scenario, beginning 

with the detection and alert system for arrivals, be it a guest or the homeowner. It covered 

the use of devices to sense a presence, authenticate individuals using a connected badge 

system, and manage the displaying whether or not entry is authorized. The setup of this 

scenario included the installation of two components: 

1. PIR motion sensor 

2. 5V passive buzzer 

3. RFID RC522 module  

4. OLED I2C SSD1306 display 


